Main (#1) - Access right - SOLVED (#19) - Message List

Access right - SOLVED
 unsolved

I'am a super admin and i can't create a Part

error at /object/create/

[Errno 111] Connection refused
Request Method: 	POST
Request URL: 	http://localhost/object/create/
Django Version: 	1.2.3
Exception Type: 	error
Exception Value:
[Errno 111] Connection refused

Can you help me ? Thank you

  • Message #67

    Hi,

    Make sure that rabbitmq-server is running:

    root@bebop:~# service rabbitmq-server status
    Status of all running nodes...
    Node 'rabbit@bebop' with Pid 1213: running
    done.
    

    The command "service rabbitmq-server start" starts rabbitmq-server.

    If you get a "socket closed" error when you create a part, it means that celery can not connect to rabbitmq. In that case, you will have to check all BROKER_* settings.

    • Message #68

      Hi,

      Thank you, the rabbitmq-server was not running. But yes, i got a socket closed error.

      Ok i will check, in /var/django/openPLM/trunk/openPLM/settings.py

      BROKER_HOST = "localhost"
      BROKER_PORT = 5672
      BROKER_USER = "openplm"
      BROKER_PASSWORD = "mypassword"
      BROKER_VHOST = "openplm"

      It is this broker ? Regards

      • Message #69

        The "BROKER_PASSWORD" should be the same as the one set by the command " rabbitmqctl add_user openplm 'PASSWORD_VALUE' ".

        If you change it, you will have to restart celeryd (service celeryd restart) and apache (service apache2 restart).

        There are logs in /var/log/rabbitmq. For example, a wrong user output something like this:

        =ERROR REPORT==== 24-Apr-2012::17:55:26 ===
        exception on TCP connection <0.4480.0> from 127.0.0.1:34256
        {channel0_error,starting,
                        {amqp_error,access_refused,
                                    "login refused for user 'openplm_false'",
                                    'connection.start_ok'}}
        =INFO REPORT==== 24-Apr-2012::17:55:26 ===
        closing TCP connection <0.4480.0> from 127.0.0.1:34256
        
        • Message #70

          it work !!! I can create a doc or a part without error

          Thank you for your help ! :)

          This command rabbitmqctl add_user openplm 'secret' not working because rabbitmq-server was stop...

          Summary :

          1 : service rabbitmq-server start
          2 : rabbitmqctl add_user openplm 'yourpassword'
          3 : service celeryd restart
          4 : service apache2 restart
          5 : vim /var/django/openPLM/trunk/openPLM/settings.py
          6 :
          BROKER_HOST = "localhost"
          BROKER_PORT = 5672
          BROKER_USER = "openplm"
          BROKER_PASSWORD = "yourpassword"
          BROKER_VHOST = "openplm"

Attachments

No attachments created.