Main (#1) - Installation Problem port :5432 - SOLVED (#17) - Message List

Installation Problem port :5432 - SOLVED
 unsolved

Hello !

I need your help please,

I try to install OpenPLM on a debian 6.0.4, I followed the installation documentation  http://wiki.openplm.org/docs/admin/ht_1_install_server.html

In Chapter : 1.1.5. Configure PostgreSQL¶

I can't do this one :

/usr/lib/postgresql/8.4/bin/postgres -D /var/postgres &
testdb6 postgres @ :/ etc $ LOG: could not bind to IPv4 socket: Address © dà © already use
TIP: Another postmaster work you dà © ja it on port 5432?
         Otherwise, wait a few seconds and try © ra.
WARNING: could not the first Crà © à © costing socket for "localhost »
FATAL: could not Crà © er of TCP / IP socket

I watched a lot of topic about the port :5432 and postgres before coming to post here...

FYI :

postgres@testdb6:/etc$ netstat -ntlp
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat                                         PID/Program name
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN                                       -
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN                                       -
tcp        0      0 0.0.0.0:5432            0.0.0.0:*               LISTEN  2289/postgres
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN                                       -
tcp        0      0 0.0.0.0:60519           0.0.0.0:*               LISTEN                                       -
tcp6       0      0 :::139                  :::*                    LISTEN                                       -
tcp6       0      0 :::80                   :::*                    LISTEN                                       -
tcp6       0      0 :::22                   :::*                    LISTEN                                       -
tcp6       0      0 :::5432                 :::*                    LISTEN   2289/postgres
tcp6       0      0 ::1:25                  :::*                    LISTEN                                       -
tcp6       0      0 :::445                  :::* LISTEN

Can you help please ? Thank you in advance, I can not continue the installation...

There is not a script for the insatlaltion ?

  • Message #61

    Hi,

    It should not be a problem if postgres is already running. Does the database creation (psql# create database openplm...) work ?

    There is no install script for the moment. All contributions are welcomed ;-)

    Regards

    • Message #62

      My firts problem isn't resolved. Yes, create database openplm... work.

      However, next :

      Create the database
              cd /var/django/openPLM/trunk/openPLM/
              ./manage.py syncdb --all
      

      I encounter this problem :

      postgres@testdb6:/var/django/openPLM/trunk/openPLM$ ./manage.py syncdb -all
      Usage: ./manage.py syncdb [options]
      Create the database tables for all apps in INSTALLED_APPS whose tables haven't already been created.
      ./manage.py: error: no such option: -a
      

      I hope I will succeed one day !... Best regards.

      • Message #63

        Hi,

        Be careful, it's ./manage.py syncdb --all with two dashes (--) not ./manage.py syncdb -all.

        Regards,

        Pierre

        • Message #64

          Hi, Thank you for your quick answer

          Wow, yes excuse me but i already tried with --all, and it's same error :

          postgres@testdb6:/var/django/openPLM/trunk/openPLM$ ./manage.py syncdb --all
          Usage: ./manage.py syncdb [options]
          Create the database tables for all apps in INSTALLED_APPS whose tables haven't already been created.
          ./manage.py: error: no such option: --all
          postgres@testdb6:/var/django/openPLM/trunk/openPLM$
          

          Other forum talk about problem with python..

          • Message #65

            Maybe south is misinstalled. There is a (solved) bug with the last version of south (0.7.4) and django 1.2:  http://south.aeracode.org/ticket/1059 but a new version has not yet been uploaded.

            You can downgrade your south package: easy_install -U 'south==0.7.3'.

            You may have to manually uninstall south: edit the file /usr/local/lib/python2.6/dist-packages/easy-install.pth to remove the line ./South-0.7.3-py2.6.egg and remove the South-0.7.4.egg-info and South-0.7.4-py2.6.egg directories in /usr/local/lib/python2.6/dist-packages/

            • Message #66

              Ok, thank you ! I will try

              Edit > It work

Attachments

No attachments created.