Changeset 465 in main


Ignore:
Timestamp:
11/10/11 11:08:19 (8 years ago)
Author:
pcosquer
Message:

update check_modules

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/openPLM/check_modules.py

    r277 r465  
     1#! /usr/bin/env python 
    12#-!- coding:utf-8 -!- 
    2 #! /usr/bin/env python 
    33 
    44############################################################################ 
     
    5656try: 
    5757    import django 
    58     if django.VERSION >= (1, 1): 
     58    if django.VERSION >= (1, 2): 
    5959        installed.append("django") 
    6060    else: 
    61         print "the version of django is too old (1.1 required, found %s)" % django.get_version() 
     61        print "the version of django is too old (1.2 required, found %s)" % django.get_version() 
    6262        not_installed.append("django") 
    6363except ImportError: 
     
    6767try: 
    6868    import pygraphviz 
    69     if pygraphviz.__version__ >= "0.99.1": 
     69    if tuple(pygraphviz.__version__.split(".")) >= (1, 1): 
    7070        installed.append("django") 
    7171    else: 
    72         print "the version of pygraphviz is too old (0.99.1 required, found %s)" % pygraphviz.__version__ 
     72        print "the version of pygraphviz is too old (1.1 required, found %s)" % pygraphviz.__version__ 
    7373        not_installed.append("pygraphviz") 
    7474except ImportError: 
Note: See TracChangeset for help on using the changeset viewer.